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Important
Copyright Information

This document is copyrighted © 2015-2016 Superbase Software Limited and is not permitted to be dis-
tributed by anyone other than Superbase Software Limited and its licencees.

All translations, derivative works, or aggregate works incorporating any of the information in this docu-
ment must be cleared with the copyright holder except as provided for under normal copyright law.

If you have any questions, please contact <info@simpol.com>

Disclaimer
No liability for the contents of this document can be accepted. Use the concepts, examples and other
content at your own risk. As this is a new edition of this document, there may be errors and inaccuracies,
that may of course be damaging to your system. Proceed with caution, and although this is highly unlikely,
the author(s) do not take any responsibility for that.

All copyrights are held by their by their respective owners, unless specifically noted otherwise. Use of a
term in this document should not be regarded as affecting the validity of any trademark or service mark.

Naming of particular products or brands should not be seen as endorsements.

You are strongly recommended to take a backup of your system before major installation and backups
at regular intervals.

New Versions of this Document
Newer versions of this document will undoubtedly be released from time to time. It is recommended that
you always ensure that you have the latest version of the documentation. Normally the latest version will
be included with any update of the main product.

Software Used
This book was written using DocBook v5.0. It was initially written and edited in the <oXygen/> editor. A
single source in XML is used to produce the book in HTML, HTML Help, and in PDF formats.
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Chapter 1. Introduction
This book provides a guide for using the Superbase NG Personal application and its associated tools for
creating and modifying databases, forms, and reports. It can also be used to enter and modify data, as
well as to import and export data. Utilities are provided for reorganizing database tables and for analyzing
table meta data.

Who Should Read This Book
If you are just getting into Superbase NG development and want an overview and basic information on the
use of the Rapid Application Development (RAD) tools that are provided, then this book is a good place
to start. If you have used Superbase in the past, many of the tools may seem fairly familiar to you. These
tools were the natural extension of those originally provided in Superbase.

Conventions Used in This Book
Throughout the book, various conventions are used to identify items such as program code, file names,
data types, etc. A fixed-pitch font is used for those sorts of things. Blocks of code are normally set
off as a separate section, and have a gray background. Emphasized items are typically in an italic font.

What Can Superbase NG Personal Do For Me?
Superbase NG Personal is an application that acts as the host for various tools that are used in the devel-
opment of SIMPOL language applications. It is not yet ready to be a standalone end-user product, but will
eventually be developed as one.

It currently includes a number of rapid application development tools, including:

• Module for creating and modifying database tables

• Design tool for creating and modifying display and print forms, plus graphical reports and label defi-
nitions

• The form designer includes the ability to save and load forms, plus saving display forms to source code

• Record, table, and form view for adding, modifying, and deleting data

• Filtered selection lists for selecting data in the current view

• Import and export tool for adding data from and extracting data to external formats

• Ad-hoc (quick) report tool for creating, running, saving and loading reports to various targets

• Graphical report tool for creating, running, saving and loading banded reports with multiple fonts, im-
ages, and more to window or printer

• Printing module for printing records, forms, system and table status

• Most-recently-used lists for tables, display and print forms, and graphic reports

The various components that are created using Superbase NG Personal are directly usable by the various
libraries that are included as part of Superbase NG.
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Where Do I Start?
When Superbase NG Personal opens, it may not be immediately obvious where to go next. Where you
start depends greatly on what you want to do. Below is a sample of the opening screen.

Image of the initial Superbase NG Personal screen.

Most of the time you will begin in the File menu. From there you can create a new database table, open an
existing one, modify the current one, create a new display or print form, modify the current form, or load
any of the most recently used items. Once a database table is open, you can add, modify, and delete data,
print the current record (or form if a form is open), run updates and create reports.

The remainder of this book will discuss the various modules incorporated into Superbase NG Personal.
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Chapter 2. The Main Screen
The main screen of Superbase NG Personal is the primary interface to reach the various modules of func-
tionality that are provided. It also represents one of those modules, namely the area where data is viewed,
entered, modified, and deleted. The program uses a linked SDI interface, which effectively means that
more than one window can be opened and be displaying database tables in form or record view. Only once
the last window is closed will the program ask if you wish to completely exit. Data sources are shared at
the application level, but each window opens tables for itself, so the same table may be open in more than
one window at a time. Each window also shows a menu and a tool bar.

The Menu
The menu in Superbase NG Personal consists of the following entries:

• File

• New

• Open

• Close

• Modify

• Recently Used

• Remove…

• Print…

• Print Setup…

• Page Setup…

• Import…

• Export…

• Exit

• Edit

• Cut

• Copy

• Paste

• Delete

• View

• Table

• Record
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• Form

• Field Selection…

• Data

• Add

• Change

• Save

• Duplicate

• Remove

• Filter…

• Quick Report…

• Update…

• Labels…

• Utilities

• Status

• Reorganize…

• Properties Browser…

• Options

• Tool Bar

• Status Bar

• System…

• Window

• New Window

• Close

• Tile

• Cascade

• Help

• Contents

• About Superbase NG Personal…

A few points should be made about some of the areas listed above. The first five entries in the File menu
are themselves submenus with entries of their own. They will be discussed in more detail later. All four
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items on the Edit menu work whenever the cursor is in an editable text control, but these four menu items
are actually meant for copying records and when not in an edit control, they work that way. The exception
is the record deletion, since it does not share an accelerator key wth the operating system. The entries Data

→ Remove and Utilities → Status are also both submenus.

The File Menu

The first entry in the File menu is the New submenu. It contains four entries: Table…, Form…, Print
Form…, and Report…. Further down is the Modify, and within this menu are three entries: Table…,
Form…, and Report…. The Table entries opens the Table Designer tool, the others open their respective
versions of the Form Designer. These are covered in their own sections: Chapter 3, The Database Table
Designer and Chapter 5, The Form Designer.

Opening Data Sources and Tables

The second entry is Open, another submenu containing four entries: Data Source…, Table…, and Form….
If no data source is open, then the Table… entry will be unavailable.

Note

An important point to make here, is that in SIMPOL we have data sources, and database
tables. Data sources are typically either a database container file or an IP address and port
number used to connect to database tables being provided by that server. This differs from
some desktop database products where the database table and the container are the same
thing.

Selecting File → Open → Data Source… will display the following window:

The window for opening SBME data sources

When the window opens it defaults to showing the information for opening a file-based data source in the
format used by the SIMPOL database engine. If a data source is already open in the current window, it
will also have the check box for "Open tables in new window" selected. The check box entitled "Show
system tables" is normally not activated. Each database container file created using the file creation tool
and most important mechanisms will automatically create three system tables in the container to hold
additional information about the tables in the container (including about the system tables themselves).
These tables are called systables, sysfields, and sysfieldsext. Between them, these tables
contain the information that is not contained in the SBME format, such as information for sharing the
table using the PPCS server, display format information, plus a place to store a comment about the field
for documentation purposes. If instead a PPCS data source is to be opened, change the source type to
ppcstype1 and the window will change slightly:
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The window for opening PPCS data sources

This window also contains an Enter data source location box, but instead of a file name, the con-
tent should be either a domain name and port number, or an IP address and port number, such as
"simpol.com:1280". The Retry and Timeout values are expressed in microseconds and default to one
seconds and five seconds respectively. The Password can be entered if one is required.

If an SBME data source is being opened and there is only one table in the container (not counting the
system tables), and if the Show system tables box is not selected, then the table will be immediately opened
without any additional steps. If, however, there is more than one possible table available in the container
file or if a PPCS data source is opened, then the "Select a table to open" window will open. From the list
shown, one or more tables can be selected. Also, if the source is a PPCS type and no tables are in the
list (table names can be hidden), a table name, if known, can be entered into the box at the bottom. This
window can be seen here:

The window for opening PPCS tables

During the process of opening a data source, the Data Sources combo box is disabled in the table selection
window. The preceding image shows the two windows spread apart, but this was done just for the picture,
normally they are centered one above the other. Once the selection(s) have been made and the OK button
is clicked, the tables will be opened and the tables and data sources windows will automatically close. At
that point, you will find yourself in Record View, as pictured here.
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A table in record view

Once a data source has been opened, the menu item File → Open → Table… becomes enabled. Selecting
that menu item will display the Select a table to open window, as seen previously, but at this point the
data source combo box can now be used to select a data source from which to select the table. This is

true even if a new window is opened using Window → New Window and the window has no tables open.
Using this technique the same table can be opened in multiple windows and positioned side by side on
different records, for example.

Opening Forms

To open a form file that has been previously created and saved, use File → Open → Form…. This opens
a standard open file dialog from which you can select the form file.

Note

Form files remember the data source information for the table that they are using. If the form
is saved using a data source that is file-based, then if the tables using that data source are not
already open, the form will attempt to open them from the last known location or from the
current directory. If that fails, it will open the form but report that it is not valid for use. If
the form is using PPCS data sources, then it will automatically attempt to connect to those
sources, unless the tables it requires are already open.

Closing Data Sources, Tables and Forms

Using the associated menu items in the File → Close menu, you can close the currently displayed table or
form. Selecting the Data Source… option will display the Select the data source to close window.
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The close data source window

From here a single data source can be selected. Any open tables will be closed (in all open windows). Any
form dependent on the tables will also close.

Note

Closing forms and tables is specific to a single window. Closing data sources applies to the
entire application.

Selecting File → Close → All will close all database tables, data sources, and forms in all open windows.

Removing Tables

If the current table is from an SBME data source, then the File → Remove… menu item will be enabled,
otherwise it is disabled (it is not possible to remove tables from a PPCS server). Superbase NG Personal
will ask for confirmation before deleting the table, and if the table is the only non-system table in the
container, an additional question will be asked about deleting the container file as well.

Quickly Reopening Recently Used Tables and Forms

There are four sub menus as part of the File → Recently Used menu. These four entries each have a menu
of entries plus an ability to display a dialog of more entries. One is for database tables, the next is for
forms, the following one is for print forms, and the last is for graphic reports. Each is managed separately
to make it more easy to find items of the specific type.

Printing With Superbase NG Personal

There are three menu items that refer to printing: File → Print…, File → Print Setup…, and File → Page
Setup…. We will discuss them in a slightly different order: Print Setup…, Page Setup…, and then Print….

Print Setup

The Print Setup item presents the following window:
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The print setup window

This window is primarily used to change the printer from the default printer to another. It is also possible
to tweak some other settings by clicking on the Preferences button.

Page Setup

The Page Setup item displays this window:

The page setup window

Select this item to modify the default font, page orientation, paper size, and margins.

Note

The page margins may not be respected by all modules; especially when printing a form, or
working with a quick report that has other page margins specified.

Print

The window displayed when this command is called is shown below:

The Print Selection window
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As can be seen from the image, there are currently six different print options:

• Print the currently displayed record

• Print the currently displayed form

• Print a selection of records from the current table using a filter

• Print a selection of records from the current table using the current form and a filter

• Print the system status

• Print the status of the current table

These options are not always enabled, they are dependent on whether a table or a form is open. The printing
of the current record is done in a very simple format:

The printed record in print preview

The Table… entry uses a filter to select the records and then simply calls the same code as the Record…
entry to print each record.

A form is printed as a rough approximation of the display form. This technique is not precise, because
display forms are designed in pixels and printed forms are designed in micrometers. On top of this, the
fonts used on display forms may look as if they have sufficient spacing when in fact, they do not allow
enough space. The two images that follow below demonstrate this problem:
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A record in form view

The printed form in print preview

As we can see in the first image, the distance between the field labels and the edit controls is considerably
wider than would normally be used on a display form. However, upon examining the printout in the print
preview window from the second image, it is clear that had the labels been any closer, the formatting would
have resulted in the labels overwriting the content. This facility is primarily intended for those who wish
to print their forms as part of their documentation, though a screen shot technique may be a better choice.

A better alternative is to create a print form for the content that is meant to be printed. A quickly designed
print form version of the form can be seen below:
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A print form version of the Contact form

When the form above is printed by selecting the same option from the dialog window, the resulting printout
looks virtually identical to what we saw in the previous image:

The Contacts print form output in print preview

When developing an application, it is often a better choice to design dedicated print forms for the content
that is meant to be printed. In a SIMPOL program, the print form can be loaded, the correct record selected,
and then be sent off to the printer or print preview window, all without ever displaying the form on the
screen.

The Forms… entry also uses a filter to select the records and then just like the one for Table… above, calls
the same code as that used for the Form… entry to print each record using the form.

An example of the system status printout can be seen here:



The File Menu

13

The system status output in print preview

The system status lists the currently open data sources, the currently open windows, and within each
window the open form (if any) and the currently open tables.

The table status shows information about the currently shown table, including its name, data source, record
count, indexed field list, and then the entire field list.

The table status output in print preview

Importing Data

The import functionality currently supports importing from CSV, ASCII-Delimited, and XML format. The
import can be into a new database table or merged with an existing one. If merged with an existing one,
the incoming data must be in the correct order (must match the field order in the table) and of the correct
data type. Importing into a new table will create only text fields, no attempt is made to assess the field data
type during import. Following the import of the data into a new table, the modify table window will be
displayed and changes can then be made to the table definition, including creating indexes. If changes are
made to the data type of fields, it is recommended to reorganize the table before creating any indexes.
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Note

Importing data such as dates and times is complicated. The data enters the database as text
and there is no easy way to convert the data into dates or times. For this sort of import, it is
better to create an empty database with the correct data structure first, and then import merge
the data into the empty database table.

Here is a sample of the import dialog for the CSV format.

The CSV import window

CSV stands for "comma-separated values" but has been modified to accept a wide array of separator char-
acters. The implementation in SIMPOL allows the specification of the field and record separator charac-
ters, supports having the first row contain field names, and allows the specification of the starting data
row. It also supports embedded newline characters. Fields containing data that include the record or field
separator characters must be delimited with double quotes. Within these sections embedded double quote
characters are doubled as an escape mechanism. In SIMPOL this format currently only supports ANSI.

The ASCII-Delimited import facility is similar to that provided by the CSV version, except that it is much
simpler. It allows the specification of field and record separators, as well as an optional field delimiter. If
defined, the field delimiter (commonly the double quote symbol) must be found around all field entries.
This format is faster but does not support embedded newline characters or other escape mechanisms aside
from the use of the field delimiter character. This format also does not currently support code pages or
Unicode. The import window for ASCII-Delimited format is shown below:

The ASCII-Delimited import window

The last import format supported is XML. The format expected is quite simple. The XML file can option-
ally start with a byte order mark (BOM) and can be in UTF8, UTF16LE (2-bytes per character Little-En-
dian) or UTF16BE (2-bytes per character Big-Endian) format. It should start with an XML declaration,
but doesn't require one. If no declaration is found, the content will be assumed to be in UTF8 format. The
root tag is assumed to be the table name, the first child tag is assumed to be the row tag. Within each row
tag should be the data. There is no support for attributes for defining data type or other information. Each
record should include all fields, even if they are empty. Here is an image of the XML import window:
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The XML import window

The format of the file is very easy, here is a sample of it:

<?xml version="1.0" encoding="UTF-8" ?>
  <DRIVERS>
    <row>
      <DriverID>0</DriverID>
      <Comments></Comments>
      <Forename>Fred</Forename>
      <Surname>Jones</Surname>
      <Telephone>555-1234</Telephone>
      <Email>fred@jones.org</Email>
    </row>
  </DRIVERS>
  

In the example, the DRIVERS tag represents the table name, and the row tag is used to group the data
into records.

Exporting Data

Just as there were three target formats supported by the import functionality, the export functionality also
supports the same three formats: ASCII-Delimited, CSV, and XML. These are the three screens that rep-
resent the export routine for each of these formats:

The ASCII-Delimited export window
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The CSV export window

The XML export window

Each of these windows shows options consistent with their output capabilities. For details about them, see
the section called “Importing Data”.

Exiting Superbase NG Personal

Selecting this menu item will exit Superbase NG Personal, closing all database tables, data sources, forms,
and windows. Closing individual windows closes only the tables and forms used by that Window, unless
it is the last window open, at which point the user will be asked if they wish to shut down the program.
Answering no will redisplay the final window.

The Edit Menu

As mentioned earlier, the entries found in the Edit menu are meant to apply to copying, cutting, pasting
and deleting records in the currently displayed table. This works as expected, but it is important to note that
if a field selection is active, then only those fields will be sent to the clipboard, when copying or cutting,
and when pasting the content of the clipboard will only be assigned to the fields in the selection, in the
order they exist in the selection. Multiple records can be pasted in one operation. Data is copied to the
clipboard as text in a tab-delimited, carriage-return linefeed delimited format. It is expected to be in the
same format when pasting.

The View Menu

There are four entries in the View menu: Table, Record, Form, and Field Selection. If no form is open, then
the Form entry will be disabled. If no database table is open, then the Table, Record, and Field Selection
entries will also be disabled. Opening a new table defaults to showing it in record view unless you are
currently in table view. If a form is shown, it is possible to switch to record or table view to see fields
that may not be shown on the form. It is also possible to change tables to examine records in those tables.
In form view, the master table of the form is set as current and the table selecting tool on the tool bar
is disabled.
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Using Field Selection

The field selection provides a method of defining a view, a list of fields from the current table (either in
record or table view) that can be a subset of the total list of fields, and arranged in any order. It can also
contain duplicates. When the field selection is active, it applies to copying and pasting of records, imports
and exports, as well as what is shown in record and table view. See below for an example of the field
selection dialog:

The Field Selection dialog

The field selection is remembered across sessions for each table, and will be presented as the default in
the dialog window when this menu option is selected.

The Data Menu
The Data menu provides a set of functions that are used to add, change, duplicate, save, and remove records
from a database table. It also has an entry called Quick Report…, which is the gateway to the ad-hoc
reporting facility. Details about that can be found in Chapter 6, The Quick Report. There is a Filter… entry,
an Update… entry, and a Labels… one. The filter functionality allows the creation of floating selection
lists and is covered in its own section, see the section called “Limiting the Results Using a Filter” for
information about defining and using the filter. The filter is actually a data snapshot. The records are read
into the floating window's grid control and once it completes new records will not be added to the list.
Further information about the labels module can be found in the section called “Getting Started Using
Labels”.

The majority of the functionality is fairly self-explanatory, but a few points may help clarify some issues.
The Add menu item will create a blank record in the current database table in record view. In form view it
will call the form's newrecord() method, which not only creates a new record, it also blanks the form
and places the focus onto the first viable control in the tab order. The duplicate function creates a new
record and then copies the current record into it, then makes the newly copied record the current record
for editing. The Remove menu has three entries: Current, Cascade, and All. The Cascade item is currently
not supported. The Current item deletes the current record in both record and form view. The final item,
removes all records from the table.

Tip

Remove → All has an optimization capability and if not used it must delete every record
individually. To use the optimization method, it is best to open the table in record view and
then do the removal of all the records. This is much faster, since the table is reorganized to
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a temporary name but without any records being copied, then the original is closed, deleted,
and the new one is renamed. This optimization cannot be used via PPCS access.

The Utilities Menu
This menu provides a windowed output of the system and table status that were shown earlier. These can
be marked and copied to the clipboard. Also the Reorganize… item is shown for tables that are disk-based.
This is a very important utility that is used to repack the database. It can also do database repair, should
an index somehow become corrupted. A standalone command line program called reorganize.smpis
also available as part of Superbase NG, including the source code to the project.

The final entry on the Utilities menu is Properties Browser. This is an early stage browser that can some-
times be useful when attempting to understand certain data structures at run time. The window opens
looking like this:

The Properties Browser

This version of the Properties Browser is still quite rudimentary, but even so, it is fairly powerful. To in-
vestigate an object, click on the cell containing the object and then click on the View button or double-click
with the left mouse button on the grid entry. To back up to the previous object, click on the Back button.
This is primarily meant for programmers that are trying to understand complex types that may be difficult
to follow in the debugger.

The Options Menu

There are only two options currently in this menu: Tool Bar → Hidden and Status Bar. Turning off the
tool bar increases the client area of the window. Removing the status bar also allows more client space to
be shown, at the cost of missing messages from the system, such as when a record is saved or the end of
the table is reached when browsing records.

The Window Menu
This menu has four entries: New Window, Close, Tile, and Cascade. Using the first option will create
another top-level window with a menu and tool bar that is identical to the first, except it will have no tables
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or form open. It can also host tables and forms, be used to start the form designer, and so on. All of these
windows are considered equal, so any one of them can do everything that the others can do, including
closing the application.

The other three entries are for managing the windows. The Close item is obvious, it closes the window. If
this is the last window, then Superbase NG Personal will ask you if you wish to close the application. If
the answer is no, the window will be redisplayed. At least one window is required. The Tile selection will
arrange all of the available windows in a tiled pattern on the desktop. The Cascade option will arrange the
windows overlapping each other on the desktop.

The Help Menu
There are only two items in this menu, the link to this handbook in Windows HTML Help format, and the
item to show the program information, including your registration number and the product version.
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Chapter 3. The Database Table
Designer

This tool is called for creating and modifying database table definitions.

Creating a Database
Select File → New → Table… from the menu. That will display the data source dialog. Since no data
sources are currently open, the combo box with the list of data sources will be disabled and the list of tables
will be empty. In the New *.sbm File Name box enter the location where you wish to create the database
container, and the name of the container file. In the Table Name box enter the desired table name.

Note

When working with Superbase hybrid applications it is a good idea to keep table names in
uppercase and no longer than 8 characters. Spaces are not permitted.

The Superbase NG Personal New Database dialog.

Now click on the OK button to create the database container and to display the dialog window where we
can define the table.

The Superbase NG Personal Database Table Definition dialog.
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To add a field, just click on the Add Field button. That will show the box for the field name, so enter that
into the box and click on the OK button. The screen will look similar to the one below:

The updated Superbase NG Personal Database Table Definition dialog.

The default data type for a new field in an empty table is string (text). It is good to change this after a number
of fields have been added, since the fields inherit the data type and other characteristics from the currently
selected field. If you move the scrollbar at the bottom to the right it will expose some more columns.
The three columns named Shareable, Share Name, and Share Type are specific to using the multi-user
database support. They determine if the field is seen in the PPCS server, if so, what its name is, and what
data type it will look like. Naturally, the field name should be valid (max 16 characters beginning with a
letter), and the data type and share type should be compatible with each other. The default assignments
tend to be adequate. The Display Format column is used for more than one purpose. It is used as part of
the multi-user database engine, but it is also used to supply the desired display format in the data-aware
form environment. It defaults to 4000 (which happens to be the maximum length of a text field that can
be accessed via the PPCS protocol used for the current multi-user support. Change that to whatever is
appropriate for the field that you are creating. Setting this value does not cause the database to restrict the
column size! The tools (like the form designer and the dataform1 system

The Display Format column in the Database Table Definition dialog.

Note

The SBME database format does not actually have any limitations on the size of a text col-
umn, or an integer, etc., but since the initial multi-user support was designed to be 100%
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compatible with Superbase's PPCS protocol, it has the exact same limitations as well. A later
version of the protocol that is not intended to be Superbase compatible is planned, and will
support all SIMPOL data types in their full capabilities. Also, the database engine only stores
what is there, it uses variable length fields to only take up the space it must.

To change the data type of a field, select the cell in the Data Type column. Click again to drop down the
selection box, as shown below, and pick the desired data type. To add an index pick the cell in the next
column, Index Type, and click again to drop down the selection box, and pick either indexed or unique
as the index type, then click on the next cell to see the results. It should look something like the following:

The AddressID entry after changing the data type and adding an index.

If you have changed a string to an integer the default display format is a bit messy. To change the display
format from the huge list of 9s to something a little more friendly and clear, such as six 0's, you can do it
either directly or via the Display Format button. To save the table definition, click on the OK button. The
final result should now be shown in Superbase NG Personal in Record View, as shown here:
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Superbase NG Personal after saving the table definition for the Address table.

Modifying a Database
Modifying a database is as easy as creating one. It is not, however, possible to modify a table that has been
accessed via PPCS. The table must be removed from the PPCS server and modified in single-user access
mode. Indexes can be added and removed. Data types can be changed. It is recommended if data types are
being changed to remove the index, change the type, save the definition, reorganize the table, and then go
back and add the index back onto the field.

Note

Please note that changing a string field to a date, time or datetime, will not give the results
that you wish. In fact, it will probably just lose the data. The date, time and datetime data
types are all stored internally as integers. There is currently no mechanism that can convert
a string to a date without using a program.
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Chapter 4. The Filter Selection Tool
This tool allows the user to create a floating selection list of records that can change the selected record
in the main window.

Creating a Selection List
Assuming an open database table in form, record, or table view, click on the = (equals) button in the tool
bar. Doing so will display the filter dialog box. In our example we are using the CUSTOMER table from
the SIMPOL Business tutorial project.

The Superbase NG Personal Selection Filter dialog

In the example we are asking to see all records that start with the uppercase letter R:
CUSTOMER."FamilyName" LIKE 'R%'. Clicking on the OK button will then show the next dialog
window, where the columns to be shown are selected. This list is retained across sessions and is separate
from the list that is stored for record and table view.

The field selection dialog

Once the columns that we wish to see are selected, click on the OK button to run the query which will start
filling the grid in the window on the left. In some cases it will happen so fast that it will finish immediately,
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in others, it may take some time and a spinning tool will be shown on the lower left part of the window.
The records are placed in sorted order into the grid. The grid will attempt to remember which item was
previosuly selected and keep it selected and in view while it is filling the list.

Tip

Hovering over the Filter label in the lower right corner will show a tool tip with the full filter
in case it is too large to be visible in the dialog window title bar.

The results window and the main window together

Selection List Sort Order
The sort order for the resulting record set cannot currently be changed. It is sorted in the order of the index
that was current when the process started. Therefore, if the sort order should be in a specific index order,
it is necessary to select that index first before starting the process.

Selecting a record in the list will cause the same record to be selected in the main view window, irrespective
of whether it is in form, record, or table view. The browsing controls can be used normally and are not
affected by the selection list. In the following image the LastFirstName index has been selected and the
sort order has changed from CustSerNo in the first sample, to LastFirstName in the second, as can
be seen from the resulting list on the left of each image.
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The results window and the main window together with new sort order
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Chapter 5. The Form Designer
The Form Designer is used to create and modify display forms, print forms, and graphic reports. Display
forms are used in Superbase NG in various ways. They can be loaded into windows, displayed in dialogs,
or even inserted into a tool bar. In fact, the tool bar in the Form Designer contains nothing other than a
form with form controls. Forms are an important and powerful way of rapidly creating database-based
application programs. It is also handy for creating the various dialog windows that are shown to get input
from the user.

Using the same basic set of tools, with some restrictions and some differences, you can use the Print Form
Designer to create forms that are primarily intended to be printed. They are designed using micrometers
(microns) as the base unit. The only controls that can be placed on a print form are the graphics, bitmaps,
and text. The bitmaps and the text items have both horizontal and vertical alignment, though the vertical
alignment can not be shown in design mode, since that is implemented using the display form capabilities,
for more information, see the Chapter 7, The Print Form Designer.

The Graphic Report Designer is a special case of the Print Form Designer. It is also what is known as a
banded report writer. There is a band for the body of the report, another for the optional page header and
footer sections, and the optional report header and footer sections. It is also possible to define multiple
groups, each of which can have a group header and/or group footer band. Each band represents the amount
of space that that particular chunk of output will take on the output page when the report is run. The entire
report form is essentially a single print form with one page for each band.

Getting Started With Display Forms
By selecting File → New → Form… from the menu, you can start the Form Designer with an empty
form. The Form Designer always opens to the size and position it previous had, and the form it creates
is normally 90% of the display size. As a first step, it is a good idea to make a few decisions about the
form being created.

In Superbase NG colors used on a form can be specified precisely as 24-bit RGB values. As an alternative,
they can be specified to use named colors that are read from the operating system each time the program
is run. The advantage to the second approach is that the form can inherit the color scheme that the user
has selected for their desktop. In some cases it will still make sense to assign a fixed value for a color. The
choice is yours. If you wish to use named colors, it is a good idea to tick the Use System Colors check
box in the tool bar.

The next important decision is how big the form should be. To set the size of the form, double-click on the

form background, or select File → Page Setup… from the menu. A window like the one below will appear:

The form and page properties window

As an example, we will set the page to 800 pixels wide by 500 pixels high and have it use the system
colors option.
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The form and page properties window again

One thing that may seem strange is that there is a form and a page name. In the design of dataform1 it was
considered to be important to allow for multiple form pages as part of a single form. Therefore the form
is a container of pages and each page contains a wxform object. If there is only one page in the form, it
makes some sense to name the form and the page the same name (the system doesn't get confused, they
are different objects). Now that we have done that, here is the work area.

The start environment

Form Designer Tools
This is a good place to discuss the various things that can be placed on a form. The tools can be divided
into two distinct groups: those that create form elements, and those that modify form elements. The tools
across the top of the tool bar are primarily for changing aspects of controls that are already on the form,
or that will be placed afterwards on the form. The tools on the bottom row of the tool bar comprise the
palette of form controls plus the selection tool on the left, and on the far right are the tools for copying
and applying control properties.

The Form Designer tool bar



Adding a Control

31

The first three tools (from the left) on the top of the tool bar are the new form, open form, and save form
tools. The next five tools are the font tools, beginning with the font selector, the font size, and then the
toggles for bold, italic, and underlined. That section is followed by the color section. This includes the Use
System Colors check box, and the combo boxes for foreground color and background color (foreground
is also called the text color). Following each combo box is a push button for selecting the foreground or
background color and another push button for applying the current foreground or background color to the
selected controls. If the Use System Colors check box is selected, then the foreground and background
color buttons are disabled and if it is not selected, then the combo boxes are disabled. The last three controls
on the top row are the text alignment controls. These only apply to controls that have alignment, such as
text and editable text.

The lower section of the tool bar contains the palette of controls and graphical elements that can be placed
on the form. Here is the list of items:

• Text

• Editable text

• Button

• Bitmap Button

• Check box

• Option button

• Combo box

• List box

• Grid

• Data grid

• Scroll bar

• Image

• Line

• Rectangle

• Triangle

• Arc

• Ellipse

Each of these items has specific attributes that affect it. To draw an element, click on the tool on the palette
or select the menu item that corresponds to the tool. Then drag a rectangle on the form that represents the
size the item should be. Upon releasing the left mouse button, a dialog will appear (these are specific to
each item being added). The dialog will already contain a large amount of preset information, including
the size of the container that was drawn, the currently selected colors, etc. Data-aware controls will also
have the ability to bind the control to a field.

Adding a Control
If the Form Designer was started with at least one open table, then it can create data aware forms. Otherwise
it needs to open tables first. To add an edit control that is bound to a field, select the edit control tool from
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the palette. Drag a rectangle with the left mouse button held down where the control should go and sized
appropriately. Then let go and the following dialog will appear.

The editable text dialog

Here we can see that almost everything we need has already been filled out for us. If we want to tweak
the starting position or the size, we can adjust the values for Left, Top, Width, and Height. Most of the
entries should be self-explanatory. If you are unclear on what any of these items do, you can check the
corresponding entry in the SIMPOL Language Reference for the wxWidgets controls.

Some items that are visible are not part of the wxWidgets controls, however, including the Data Table and
Bound Field. Drop down the combo and select a table, and then from the list of fields select a field. It is
also a good idea to give the control a useful name that has meaning. If the Create field label check box is
selected, then a text control with the appropriate label will be created as well.

The editable text dialog after changes

Clicking on OK will create the control and close the dialog. Here is what the result looks like.
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The editable text control on the form

As can be seen from the image, the label has been created and has the correct color, but the edit con-
trol is not very readable. Drag a rectangle around the edit control, completely enclosing it or just click
on the control. Either will select it. Then select CLR_WINDOW from the background color combo and
CLR_WINDOWTEXT from the foreground color combo. Then select each of the Apply color buttons to
change the control's color. The result can be seen here.

The fixed editable text control
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A similar approach is used with all of the controls. Experimentation is the best way to get to know the
controls and the Form Designer.

Note

If you select multiple fields when creating an editable text control, it will create as many
controls as selected (assuming they fit on the form vertically). This is a very fast way to
create a group of edit controls and their labels. The names will be created as tb plus the field
name to make identification easier.

More Form Designer Tools
There is a set of tools that are located on the right mouse menu. This includes the following capabilities:

• Edit

• Delete

• Select All

• Move to Front

• Move to Back

• Align

• Adjust Size

• Distribute

• Graphic Properties

• Detail Blocks

To align or size the selected items, after choosing the type of operation from the menu, click on a control
(or the page) to apply the operation to the selected controls.
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The right mouse button pop-up menu

There are some more tools in the Define menu. These are File Links, Tab Sequence, Detail Blocks…, and
Graphic Properties.

The File Links tool is used to link the master table to other tables and also with data grids and detail blocks.
Links to tables are always 1:1 links. Links to data grids and detail blocks are called 1:n links. It is also
possible to have more than one table in a detail block or data grid, and in the dialog windows that are used
to define the content of those a Links… button is placed to show the same tool.

The tab sequence of the controls is exactly the same as the z-order. Imagine the controls stacked on top
of each other. The bottommost control has the tab order number 1. The next is 2, and so on. If a control
lower in the tab order is partly covered by a control higher in the tab order, then the control lower in the
tab order will be partly obscured by the control that is higher.

Important

The wxWidgets tool kit does not specifically define behavior for controls that overlap. It is
a bad idea to try and combine controls in this way, although it is safe to overlay controls
on bitmaps and graphics. Graphics: lines, rectangles, triangles, arcs, and ellipses are always
below the other form controls. They cannot overlay the form controls.

Detail blocks take a group of controls, which can include: text, editable text, check box, and combo box,
and treat them as a type of grid. They can be defined with multiple rows, multiple columns, or both. They
must be linked to the master record of the form in order for the content to automatically be updated. Detail
blocks are read only, but can provide a form of localized report. Detail blocks can also be unlinked (to the
outside – they still must have links if they contain multiple tables internally). Unlinked tables also exist,
but they are managed by the programmer, there is no automatic support for them.
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Saving and Loading Forms
Forms can be saved in the Superbase NG XML format and use the file extension .sxf. They can also
be saved as SIMPOL source code. This is quite useful, especially for creating dialogs, since they can be

compiled into the program rather than loaded at runtime. To load a form simply select File → Open →
Form… from the menu. If the current form is modified, you will be prompted to save it. The resulting
file open dialog can be used to open either a print form or a display form, but if called from the Form
Designer, it will default to display forms.



37

Chapter 6. The Quick Report
The Quick Report component is provided for the creation, modification, saving, loading and execution of
ad-hoc reports. The design of SIMPOL is strongly oriented toward supporting industry standards, and the
query engine continues with that by using a subset of SQL92 as its query language. The Quick Report tool
removes the need to learn SQL92 so that it is quick and easy to click together a report. The resulting report
can be stored for later use, and the output can be directed to print preview window, directly to printer, the
clipboard, CSV file, or HTML file. More targets are planned for the future.

Getting Started
When it is started, the Quick Report window looks like this.

The initial Quick Report window

A Quick Report consists of the following components: the selected columns, the filter or where clause, the
order clause, any group definitions, and aggregate calculations at the group or report level. The formatting
of the report when printed is fairly basic, with only one font used for the column heading and body, but it
produces quite usable reports. The HTML output can be manipulated using CSS, but comes with a built
in style sheet if no other one is specified.

The clipboard target and the CSV target both ignore any grouping or aggregate calculations. The clip-
board target copies only the data to the clipboard, using a tab-delimited, carriage return/linefeed-delimited
format. This makes the clipboard content very easily paste as rows of data into many products, such as
spreadsheets. The CSV format is a better choice for transferring data if the data contains the tab character
or the carriage return or line feed characters, since it can safely escape these when exporting the results.
The CSV target also uses the column names as the field names in the first row of output.

Adding Columns
To make it easier to try out the various examples in this chapter, the CONTACT table used in the example
has been included in the distribution. It can be found in the samples\data directory. Just double-click

on it from Windows Explorer or using the menu, select the Open → Data Source… item. The table is in
a data source file called contact.sbm.

The first step when creating a query is to add the columns that should be output. Using the CONTACT
table, it might look like this:
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The Quick Report window after adding columns

Looking at the image, a few things become apparent. The required page size for the columns and column
widths as shown is 111 mm. Also the columns are currently all the same width. The paper size is currently
set to A4 (in some countries it may be set to US Letter).

Sizing Columns
The next step is to widen or narrow the columns as required. Doing this is very easy; just hover the mouse
over the border between columns and when the cursor changes to a sizing cursor, just left click, hold,
and pull the mouse to one side or the other to resize the column. When the column size has changed,
the information will update on the screen, including the required page width. If the required page width
exceeds the current paper width, the text will change color to red and will become bold, to draw attention
to the problem.

When a column is resized, the column affected will be selected in the Columns list and that will then enable
the Column Settings area and show the information specific to that column.

The Quick Report window after resizing columns

Setting Remaining Options
At this point, the report could already be run, but depending on the target it may be worth setting some
additional options. For window or printer output, it may be useful to select the Show Date check box, the
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Show Page Number check box, and to give the report a title. If going to HTML use either the default style
sheet, or add the name of an external style sheet if modifying the style.

The Quick Report window after setting print options

Running the Report

At this stage we can already run the report to create a list of contacts. Click on the OK button and then the
progress bar window will appear as the report is running. When the report is complete, it will appear in
the print preview window. The following image shows the result.

The Quick Report output from the first run

As we can see from examining the output, the records are not in any apparent order, although they are
predominantly in order by last name. That is probably a coincidence of the way the data was created. The
report order was not defined, so the result is also not guaranteed to be properly sorted. The report is 17
pages long, but it could be made far more useful with a little more effort.

Adding a Sort Order
Click on the Order button to display the Sort Order Definition window. To begin with, no sort order is
defined. Here is what it looks like:
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The initial sort order window

One thing that may not be immediately obvious, is that the window only shows the names of the output
columns on the left-hand side. That is because the engine only supports sorting on the output columns. To
make our results more useful, we will sort them on the LastName column in ascending order.

The first sort order

Click on the OK button to confirm the sort order and then click on the OK button on the main window
to run the report again.

The report with a sort order

This report output is better than what came before. The records are now sorted by last name, making it
easier to find someone. Still, we have a lot of people with the same last name, so it may be worth also
sorting by first name within each group sorted by last name. To do that, click again on the Order button,
double-click on the FirstName entry in the Columns list, and then click on OK to commit the change and
close the window. Now click on the OK button to run the report again.
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The report with a double sort order

From the result we got this time around, it is much easier to find an individual in our list. Still, with a
little more work we can also find people potentially faster and also learn how many people we know in
various areas.

Groups and Aggregate Calculations
One way to organize the output of the report is to group it. Groups also have the restriction that it is only
possible to group on data that is actually part of the report. In the case of our contact list, it might be useful
to group on the State column. Within that we can still sort by last name and first name. To create or modify
the group information, click on the Groups button.

The initial groups window

At the beginning there are no groups defined, other than the permanent group that represents the report
itself. Start by adding the State column to the Groups list. Then click on the State entry in the Groups list.
The window will look something like this:
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The groups window with a group selected

There is not a large amount of difference to see, since we do not have any numeric columns in our report
and the aggregate calculations can only be applied to numeric columns. One thing that has changed is that
we can now select the check box entry called Count Group Rows. We will do that now. Then click on the
<report> entry and also select the Count Group Rows entry for the report. This will count the rows in each
group plus the total number of rows in the report.

Note

To create aggregate calculations for the group or report, assuming that the report contains
appropriate columns, click on the entry in the Column for aggregate list. That will enable the
items in the Aggregate Calculations box. Select the calculations that you want. If column 1
in the report does not contain an aggregate calculation, then clicking on the Output aggregate
names check box will ensure that the name of the relevant aggregate calculation will be
output in column 1 in both the after group and after report sections.

Now that the group and report count items have been selected, click on OK to commit these changes and
continue. At this point we have defined a group on the State column, but that is not yet in the sort order.
There was a button to set a usable sort order in the Groups window, but that would have overwritten our
current one, so we will just change it by hand. Click again on the Order button, and then double-click on
the State entry in the list. It is now in the list on the right. That isn't enough though, because it needs to be
first in the sort order, otherwise we will get dozens of groups with the same name but different content.

The order window after adding a new entry

To move the State entry to the top, click on it in the Order Columns list. The top two arrow buttons will
be enabled.
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The order window after selecting a sort entry

Click on the top arrow (this means "move to first", the second one means "move up one"). That moves
the State entry to the beginning of the list. The report will now sort in the correct order. To run our more
sophisticated report, click on the OK button to commit the change to the order clause and then click on
OK to run the report. The result can be seen in the following image.

The output after creating a group

Close examination of the result will show that results are now grouped by the State column. Within the
group the entries are sorted by last name and there is far less often duplication of last names, but in the
few cases we can see, these entries are further ordered by the first name.

Output to HTML
Outputting our results to HTML is as easy as selecting HTML from the Destination combo box and then
running the report again. You will be asked for the name of the target output file. After entering the
output file name and clicking on OK the report will run. When it completes, it will show a window and
ask if you wish to view the output in a browser. Clicking on Yes (currently Windows only) will use
shellexecute() to open the file in the default browser. The image below shows some report output
in HTML using the default style sheet.
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The output in HTML

Limiting the Results Using a Filter
Although in many cases we may wish to see all of the data from our database table in the results, in many
cases we may actually only want to see a portion of the data. Especially in the case of something like an
order-taking system we might only want to see the turnover for the previous quarter, or the previous year.
That makes it very important to be able to limit the results. In SQL92 this is called the where clause. We
also often speak of it in terms of a filter, that only allows the data through that matches our criteria. To
access the filter definition window, click on the Filter button.
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The initial filter window

The filter can be defined using either the columns from the report's select clause, or any of the fields
from the tables that are part of the query. In the case of this data, since it was generated randomly, the
Zip field is not directly associated with the state. This is not normally the case, but for our purposes it
helps to demonstrate the filtering. We will switch the <Columns> combo box to use our table. From that
list we will select the entry Zip.

The partial filter

Now click on the LIKE button. The LIKE operator is used when we wish to use pattern matching on a
piece of text. In the subset of SQL supported by the query engine, the wild card character that matches
any number of other characters is the percent symbol. The replacement for any single character is the
underscore. In the Text box enter 9_2% and click on the OK button at the end of the box to add it to the
filter. It should now look like this:
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The completed filter

If you wish to edit the filter directly, click on the Edit check box. Doing so will disable all of the buttons
in the rightmost column.

Tip

Hovering the mouse over any of the function buttons in the far right column will show the
syntax of the specific function. Also, when using these buttons, more strict manipulation of
the interface will occur, in order to assist with the creation of the formula.

Click on OK to commit the changes to the filter and return to the main Quick Report window. Then click
on OK to run the report.

The query output filtered

A close look at the results shows that the query output has gone from 18 pages to just 3. Examining the
Zip column shows that all of the zip codes listed fit the pattern.



Further Steps

47

Further Steps
This chapter has introduced the Quick Report tool. To truly get to know what it can do, the best solution is
to play with it, try things out. In some cases it will require more complex tables with numeric fields and in
others having tables that can be linked. Also, don't forget that Quick Reports can be saved and then loaded
from a program and the filter can be set at run time just before executing the report, so you can also use
this tool to build pieces of a packaged application. For a full list of syntax information see below.

The SQL92 syntax supported is:

• [TABLE_NAME.]COLUMN_NAME, [TABLE_NAME.]COLUMN_NAME AS

• AND OR NOT

• = > < >= <= <>

• [NOT] LIKE '' ESCAPE

• unary +, unary -, +, -, *, /, || (string concatenation)

• POSITION( <string> IN <string> )

• EXTRACT( YEAR | MONTH | DAY | HOUR | MINUTE | SECOND FROM <date-time-or-datetime>)

• CHAR[ACTER]_LENGTH( <string> )

• UPPER( <string> )

• LOWER( <string> )

• SUBSTRING( <string> FROM <start-position> [ FOR <length> ] )

• TRIM( [ [ LEADING | TRAILING | BOTH ] [ <trim-char> ] FROM ] <string-to-trim> )

• CAST( <value-expression> AS <data-type> )

• ABS( <numeric-expression> )

• CURRENT_DATE

• CURRENT_TIME

• CURRENT_TIMESTAMP

Here are some additional notes about working with dates, times, and datetimes:

• Dates must be supplied in the format yyyy-mm-dd when expecting to evaluate them

• Times must be supplied in the format hh:mm:ss[.ssssss] not all decimal places required

• Datetimes must be supplied in the format yyyy-mm-dd hh:mm:ss[.ssssss]

To evaluate a date, time, or datetime, it needs to be prefaced by the appropriate operator:

• DATE('2010-01-26')

• TIME('23:21:55')
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• TIMESTAMP('2010-01-26 23:21:55')

To escape the single quote mark (') in an SQL string, use another single-quote mark:

Example 6.1.

        string where, errmsg
        integer erridx
        
        where = "Surname LIKE 'O''Reilly"
        query.setwhereclause(where, errmsg, erridx)
      

The following key words are supported: AND, ABS, AS, BOTH, CAST, CHAR_LENGTH,
CHARACTER_LENGTH, CURRENT_DATE, CURRENT_TIME, CURRENT_TIMESTAMP,
DATE, DAY, ESCAPE, EXTRACT, FOR, FROM, HOUR, IN, LEADING, LIKE, LOWER,
MINUTE, MONTH, NOT, OR, POSITION, SECOND, SUBSTRING, TIME, TIMESTAMP,
TRIM, TRAILING, UPPER, YEAR.
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Chapter 7. The Print Form Designer
The Print Form Designer is used to create and modify forms meant to be printed rather than used for
display or data-entry. In SIMPOL there is a distinction between forms meant for display and data-entry,
and forms for printing. In fact, printable forms do not ever need to be shown on the screen. They can be
loaded, populated, and printed without ever showing them to the user. In general, forms designed for the
screen need to meet different criteria from forms meant to be printed, and it is generally considered to be
poor design to use a printed form layout for data-entry. Superbase NG printable forms have the extension
.sxp and as with most other Superbase NG storage formats, it is stored in XML.

Getting Started
By selecting File → New → Print Form… from the menu, you can start the Print Form Designer with an
empty form. The Print Form Designer always opens to the last size and position of the Form Designer, but
the initial print form will be in the default paper size for your system, typically either A4 or US Letter.

The initial Print Form Designer window

It is always a good idea to set the default values for the form when you first begin, although in this case
most of the defaults tend to be quite usable. Still, when you double-click on the page it will display the
Page Setup dialog, where the paper size and the orientation can be selected, along with the caption for the
Print Preview window and the page orientation.
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The Print Form Designer page settings dialog

Note

Don't change the width and height if you change the orientation to landscape. Internally the
code will swap the width and height values if the page orientation has been set to landscape.

There are a large number of paper formats catered for in the system, as can be seen from the expanded
combo box image below:

The expanded Print Form Designer page settings dialog

Print Form Designer Tools
As with the Form Designer, the tool bar contains two types of tools: those that create form elements and
those that modify form elements. The controls across the top of the tool bar are there to set attributes of
the items on the form, whereas the ones at the bottom are mainly for drawing items on the form. The tools
on the bottom row of the tool bar comprise the palette of form controls plus the selection tool on the left,
and on the far right are the tools for copying and applying control properties.

The Print Form Designer tool bar

Just as in the Form Designer, the first three tools from the left are the new form, open form, and save form
tools. These are followed by the five font selection tools. The Print Form Designer defaults to Times New
Roman 12pt. At this point things begin to diverge from the Form Designer. This is because the things that
are printed to paper have different characteristics to those shown on the screen. One of the printing options
for text controls is whether the background color is visible or not. Also, this system does not support
named (system) colors, since the color scheme of the operating system is irrelevant to the printing of a
document to paper.

The significant change on the first row of tool bar icons are the final three alignment tools. These represent
align top, middle, and bottom. Both text and bitmaps in the print architecture can be given alignment
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instructions both horizontally and vertically. These capabilities do not exist on the screen, so the display
of these attributes is not possible during design, but they will be correctly output.

The second row of the tool bar has quite a few less tools on it than are found on the Form Designer tool
bar. That is because a print form only supports text, images, and graphics. The functionality is essentially
the same as provided by the Form Designer.

The lower section of the tool bar contains the palette of controls and graphical elements that can be placed
on the print form. They are listed below:

• Text

• Image

• Line

• Rectangle

• Triangle

• Arc

• Ellipse

Each of these items has specific attributes that affect it. To draw an element, click on the tool on the palette
or select the menu item that corresponds to the tool. Then drag a rectangle on the form that represents the
size the item should be. Upon releasing the left mouse button, a dialog will appear (these are specific to
each item being added). The dialog will already contain a large amount of preset information, including
the size of the container that was drawn, the currently selected colors, etc. Data-aware controls will also
have the ability to bind the control to a field.

Adding a Print Control
If the Print Form Designer was started with at least one open table, then it can create data aware print
forms. Otherwise it needs to open tables first. To add a text control of any type, select the text control tool
from the palette. Drag a rectangle with the left mouse button held down where the control should go and
sized appropriately. Then let go and the following dialog will appear.

The text dialog

If a database table is already open, then it will be pre-selected when the dialog window opens. To create
static text entries on the form, just select <None> from the Data Table drop down box and then enter the
text in the Text box in the upper right-hand corner. Text can be single or multi-line. To bind the text entry
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to a control, select a database table from the Data Table drop down box. Then select a field from the Bound
Field list box. The default colors are black text on white background and the background is not meant to
be shown. The alignment defaults to the upper left corner. Changing the alignment will only display the
horizontal portion on the form, but it will print correctly. Please note that the coordinates in the boxes: Left,
Top, Width, and Height, are all in micrometers, the default unit for Superbase NG forms. Currently there
is no support for displaying in a different measurement format, though it may be added as an enhancement.
All controls are marked as Printable by default. If some text should be added as instrcutions to the user,
but not printed, if the Printable is unchecked, then it will not be printed.

Tip

It is important to size text boxes with a fairly generous amount of height, since otherwise
during print preview at various magnifications, the tet may not render at all. It is easiest to
establish how much space to leave from experience and a bit of testing.

More Print Form Designer Tools
There is a set of tools that are located on the right mouse menu. This includes the following capabilities:

• Edit

• Delete

• Select All

• Move to Front

• Move to Back

• Align

• Adjust Size

• Distribute

To align or size the selected items, after choosing the type of operation from the menu, click on a control
(or the page) to apply the operation to the selected controls. To distribute items either horizontally or
vertically, select the items and then the desired operation.

There is a Tools menu in the Print Form Designer, rather than a Define menu as found in the Form Designer,
and it has a slightly different composition as well. It contains the following menu items:

• File Links

• Z-Order

• Test Print

The File Links tool is used to link the master table to other tables. Links to tables are always 1:1 links. If
the need is to have a 1:N type of link, then the proper choice would be either a Quick Report or a Graphic
Report, rather than a static print form. The Z-Order is used to affect the stacking order of controls on the
output form (there is no tab order because none of the controls can receive focus). The final entry, Test
Print, is used to do a test print of the form, though entries that contain a field from a record may not show
anything in the test print.
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Saving and Loading Print Forms
Print forms can be saved in the Superbase NG XML format and use the file extension .sxp. There is

currently no mechanism to save them as SIMPOL source code. To load a form simply select File → Open

→ Form… from the menu. If the current form is modified, you will be prompted to save it. The resulting
file open dialog can be used to open either a print form or a display form, but if called from the Print Form
Designer, it will default to print forms.
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Chapter 8. The Labels System

Getting Started Using Labels
When it is started, the Labels window looks like this.

The initial Labels window

A labels definition consists of the logical definition stored in an *.sxl file and the print definition stored
in an *.sxp file, which will be referenced by the logical definition file. The basic design of the labels
system is that a print form with a page size the same as the physical label is defined and used to output the
data. The logical label definition is responsible for the paper size, layout, output order, and stores the list of
controls considered to be collapsible. Any control marked as collapsible if it contains no data on a specific
instance of a label output will cause the controls on the page below it to be repositioned to close the gap.

Selecting or Defining a Label Layout
The first step from the labels window is to create a label definition. Clicking on the New button will display
the SIMPOL Label Definition dialog window as shown here:

The Superbase NG Labels Definition window

The list of which labels are available and their dimensions and layout are stored in the
sbngpersonal.ini file. If a format is not found in the list, it can be defined and added to the list
here. The blank page to the right is reserved for showing in the future an image representing the label page
layout. The default one shown is currently the 2 across, 7 down label format, since it is one of the more
popular label types used. Once the label format has been chosen, clicking on OK will lead to the SIMPOL
Label Designer, which is a slightly modified version of the SIMPOL Print Form Designer.
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The Label Designer

The Superbase NG Label Designer window

Working with the actual design tools is the same as with the Print Form Designer, so we won't go into that
in detail here. The significant difference between the Print Form Designer and the Label Designer is that
the page size matches the individual label size, and the page setup always shows the label definition dialog
window. Also, there are a couple of special menu commands that can prove very useful. First however,
let's have a look at our finished label definition.

The Superbase NG Label Designer window with finished label
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At this point, it is useful to look at the special commands on the Tools menu. One of them is an item
called Collapsible Controls…. This is used to assign the collapsible trait to the controls that should be
collapsed (closed up) if they are empty during the rendering of the label. In the image below we show that
we have chosen to allow the lOrganization, lAddress1, lCity, lRegion, and lPostCode controls to collapse
if they are empty.

The Superbase NG Label Designer collapsible controls dialog

Another highly useful feature that is also found on the Tools menu is the Test Print feature. It will show the
layout with the various controls placed in the correct positions for a single sheet of paper. All of the text
controls are filled with the letter "E", so the layout can be checked. A common problem when designing
these layouts is not allowing enough vertical spacing in the text bounding box, which results in the content
not appearing when printed (because there is insufficient height to render the text with the assigned font).
Another problem occurs when the box is close to the right height, but in the middle a bit. Then, at some
resolutions in the print preview window the content will appear and at others it will disappear. Below is
an image showing the test print of our label.

The Superbase NG Label Designer Test Print output
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After saving the label definition we are returned to the SIMPOL Labels dialog window where we can also
specify a filter and a sort order.

Running the Labels
Both of these dialogs are borrowed from the Quick Report library. For information about their use, see the
section called “Limiting the Results Using a Filter” and the section called “Adding a Sort Order”. The sort
order capability only works on fields that are output as part of the query, and that is constructed from the
controls on the label, so currently it is necessary to ensure the sort field is shown on the label (even if you
make it tiny and invisible if it is not meant to be seen). Here we see the dialog window with everything
defined and ready to go.

The Superbase NG Label dialog window ready to run

Selecting the Run to Window button will send the output to the print preview window, whereas the Run to
Printer option will send the output to the printer. Selecting the Close button will close the dialog without
running the labels definition, though if one has been loaded, it will still be loaded unless the current table
is changed. Below we can see the first of 30 pages of output from our label definition. An example of the
collapsing or closing up of the empty controls can be seen in the top right label and again with bottom
right (visible) label.

The Superbase NG Label output
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Chapter 9. The Graphic Report
Designer

The Graphic Report Designer is used to create and modify reports in the style of a banded report writer.
These reports allow a great deal of customization and support text items with various fonts and font sizes
as well as images and graphical elements. Each band of the report represents a portion of the report: the
page header, page footer, body, report header and footer, along with headers and footers for each defined
group. Superbase NG graphic reports have the extension .sxr and as with most other Superbase NG
storage formats, it is stored in XML. Essentially, a graphic report contains a print form together with a
report definition.

Getting Started with Graphic Reports
By selecting File → New → Report… from the menu, you can start the Graphic Report Designer with
an empty report. The Graphic Report Designer always opens to the last size and position of the Form
Designer, but the width of each band of the initial report will be in the default paper size for your system,
typically either A4 or US Letter.

The initial Graphic Report Designer window

There is a window for each band in the report. Initially the report is created with a body, page header, and
page footer. Internally the form is treated as a print form template with each band being a page of that
form. When the report is run, a separate internal print form template is created for each page, with the page
header being applied to it first. At that point, the current output row from the report is used to populate the
controls that are part of the body band in a copy of the body band template. This band is then added to the
output in the current offset from the top of the page. As each row is generated by the report engine, it is
added to the report page until there would be no room for it and the footer (if defined). At that point, the
old page is finalized and a new page template is opened. The page header (if defined) is applied and the
output row is then added to the new page. This continues until the last output row is processed.

If a report header band is defined, then at the start of the report, the report header band will be output
immediately after the page header. The body entries are then output as described earlier, and after the last
body entry, if defined, a report footer will be output followed by the page footer. Often it might be desirable
to suppress the page header or footer on pages where a report header or report footer will be output and that
option is available as will be shown later. Here is a sample report with report header and footer as well.



Graphic Report Designer Tools

60

The Graphic Report Designer window with report header and footer

Both the Quick Report and Graphic Report operate using the banded concept. The significant difference
between the two, is that in the Quick Report, the definition of the contents of each band is done using
the same font and positioning as the items in the body band. There is limited ability to customize the
report. At the same time, those reports are fairly easy to define and run and can be output to a number of
different targets. A Graphic Report has considerably greater flexibility in terms of what it will look like,
but currently is only designed to output to the print preview window or directly to printer.

Graphic Report Designer Tools
Since internally the form portion of a graphic report is a print form, all of the same tools that can be used
on a print form can also be used on a graphic report. As such, we won't repeat all of that information here,
it can be found in the section called “Print Form Designer Tools” and the section called “More Print Form
Designer Tools”. Instead, we will concentrate on the tools that are different.

There is a Tools menu in the Graphic Report Designer, as is the case in the Print Form Designer, but it has
a slightly different composition. It contains the following menu items:

• Z-Order

• Headers, Footers, and Properties

• Groups

• Order

• Filter

• Test Report

One item that might be thought is missing is the File Links menu item. That functionality is incorporated
in the Filter menu item. The Z-Order is used to affect the stacking order of controls on the output form.
The Headers, Footers, and Properties item is where we select which header and footer bands are displayed.
The Groups item is where we can define the way the output data is grouped, including options to enable
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group header and footer bands. The Order menu item allows the sort order for the report to be defined.
In the Filter entry we can set the filter conditions and define how multiple tables are linked together. The
Test Report item allows the entire report to be run, including any options that have been selected. This is
an excellent way to ensure that the report design is doing what it should do.

A Basic Graphic Report
In the next few sections we will be working with the data that is supplied as part of the SIMPOL Business
sample program. For our initial report, we will create a customer list, grouped by country, last name, and
first name. For each country we will output the number of entries in that group. At the end, we will output
the total number of entries.

Starting with an empty report, one of the first things we will do is to bring up the Headers, Footers, and
Properties dialog window. There we will select the features we intend to use. Here is an image of it:

The Report Properties dialog window

In this dialog the Report Footer, Page Header, and Page Footer options are selected. Before we go on,
let's look at the other options. In the upper section of the dialog window are various options that affect the
running of the report. The entry for Allow User-Defined Order and Allow User-Defined Filter, if selected,
will cause the report engine to show the user the order and filter dialog boxes so that they can modify the
content before the report is run. The Links button in the filter dialog is unavailable during this, since users
should not be changing the form linkage, merely refining the output. When these items are selected, the
hide items next to them are enabled. If they are selected, then the built-in filter and order clauses will not
be displayed, and they will be reinserted in front of any user defined items. The Prompt for Destination
item will show a dialog asking the user whether to send the report to window or directly to the printer.
The next item in the top section is Distinct. Just like the same named item in the Quick Report, this is used
to suppress multiple output rows that are identical. This is something that can happen depending on the
design and linkage of a report filter, so this feature can be used to cope with that. The final item in the top
section is Null is Zero, which is used just like in the Quick Report to ensure that any numeric field, if it
contains a null value, will be set to 0 for the purpose of the report.

In the lower section of the dialog window we see the four options for enabling the page and report headers
and footers. Earlier the Omit items were mentioned. It is not uncommon to omit the page header on the
first page if there is a report header, which will do the job of both. Sometimes a report may be designed
with a special page as the report header, in which case it may be useful to also omit the page footer on
the first page.

Once the required attributes of the report have been selected, the initial page might look like this:
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The Graphic Report Designer with page header and footer, body, and report footer

Adding items to the report bands is the same sort of thing as adding items to a print form, so we won't go
into the details of how to add basic items on the report. The body pane is for the fields from the report that
make up the actual core output. The reportfooter pane is where information for totals or other aggregate
calculations over the entire report can be placed. In the image below is shown the state of the report with
the fields in the body pane and the column headings and page title in the pageheader pane.

The Graphic Report Designer with text elements in the page header and body

As a next step, we will add today's date as a calculation to the pageheader pane.
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The Text Properties dialog adding the calculated value for today's date

The calculations that are available for a given band are found in the Calculation combo box. The content
of the Text box is irrelevant, since they will be overwritten by the calculation when the control is assessed
during output. This is being placed on the right side of the page header, so it has been right-aligned. Using
the same approach, a page number was added to the page footer, as can be seen in the following image:

The report with the calculations for TODAY and PAGE

To complete the initial cut of the report, a sort order will need to be added. This can be found in the Tools
menu by selecting the Order item. Upon doing so, we see something similar tot he image shown below:
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The sort order dialog

Carefully examining the list on the left side will show that, just as with the Quick Report, the columns
used in the sort order must be present in the report output. Since we don't have the FamilyName field
in our output, we will need to add it, but if we don't want it to appear, we will need to make it invisible.
That is easily done by adding it and deselecting the Visible check box. That makes the entry completely
invisible, so to find such entries it is often easiest to use the Select All command. In the image below two
entries have been added and set invisible, one for the FamilyName and one for the FirstNames field.

Note

A later version of the designer will add a feature that places a box around each control,
making it easier to find and select them.

The report with the two invisible field entries selected

Now that we have all of our fields represented in the body line, when we show the sort order dialog, we
can add all of the columns we need.
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The sort order dialog with the desired sorting criteria

After a bit of rearranging and widening of some fields to take full advantage of the horizontal space offered
by the paper, and after stopping the report early, we can see a sample of the resulting output.

The report results in the print preview window

Developing the Customer Report Further
So far the report produces a list, but it would be useful if it gave us a total for the number of customers
in the report. To do this we need to add a calculation in the report footer page. The image below shows
how we add a calculation to the report footer band.
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The Text Properties dialog when adding the COUNT calculation

It is a good idea to select a field from the list, even though it may not seem necessary for the COUNT
operation. Doing so helps to describe what is happening in the design view

The report footer could also use some text to describe the number that will appear, so a text item reading,
"Total number of customers:" is added in front of the calculation. The result looks like this:

The Text Properties dialog when adding the COUNT calculation

After running the report, the there are 112 output pages and on the final page the total customers is shown
in the the rport footer section, like this:

The Print Preview window showing the last page of the customer list

The report now gives us totals for the report, but it might be nice to also know how many customers are
located in each country. To make that work, the report needs to have a group added. The dialog window
shown below has added the CountryCode column as a group and the Group Footer Band option has been
selected.
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The Groups Definition dialog with a group on CountryCode

Adding a group with a group footer adds a band to the report. In that band, just as was done in the report
footer, a COUNT calculation and explanatory text item are added. Our final version of the report definition
looks like this:

The report with a group footer band for the CountryCode group

When this report is run, it will also produce total for each country. In our sample the report was stopped
before it completed, so that we could see more than one group on a page, and the available output was
viewed. This is what it looks like:
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The report output showing multiple groups with totals

An Invoice Using the Graphic Report
Now that we have created a customer list and learned a bit about graphic reports, it is worth trying out
something more ambitious. We will create an invoice for the customer using the Graphic Report Designer.
This report is based on the orignal report we shipped with the SIMPOL Business sample, but unlike that
example, which required some coding we thought it might be useful to create one that is done purely by
the report engine.

The initial version of the report, as loaded from the invoice.sxr file can be seen here:
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The original invoice graphic report definition

The graphic report definition shown above uses a report header to host the information that is read from
the ORDERMST table. The controls for those are not visible, because they are in the report header, and as
such they are simply empty text containers and those are filled by the program in the onoutput event. If
a report header is used there is little other choice since at the point where the report header is processed
in the engine no data has yet been read and therefore it is not possible to put data into these controls (the
engine does not pass any data to the function that handles this band of the report). A better solution is to
use a group header and group footer. At that point, the data is available. The report as it is will work, but
requires program code to put information into the controls. To convert this to the version we need, the
easiest approach, and the one used, is to add a group. To do that, an extra body field is required. We added
the ORDERDTL.OrdSerNo field in an invisible control to the left of the ORDERDTL.ProdSerNo. We
then grouped on that and added both the header and footer ands for the group. We then sized them to
match the report header and footer. Finally, the items from the report header were selected and copied to
clipnoard and then pasted into the group header, and the same was done with the footer. When everything
was across, the report header and footer were removed. The result looks like this:
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The reworked invoice graphic report definition

Things that immediately stand out are the field names that were empty before. Since this is a group header,
it has access to all of the data. Internally, the designer adds every field that is mentioned in the body or
in group headers and footers into the select clause so that its data is available at the point of output. To
make this whole thing work, we also had to change some settings in the Report Properties window. We
only want one invoice from one order, so after linking up the two tables in the filter (where clause), the
Allow User-Defined Filter and Hide Specified Filter options are enabled in the Report Properties dialog
window. That means that when the report runs, the specific order serial number can be set in the filter and
that invoice will be produced.
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The report properties for the invoice

Once everything is ready, we can try it out by using the Tools Test Report menu item. Selecting that
item immediately presents the filter dialog. It is necessary to use the TableName.FieldName syntax
here, because the OrdSerNo field is present in both ORDERMST and ORDERDTL tables and is therefore
ambiguous.

The filter dialog during running of the report

The output result is the invoice we expected to see.

The report output in the print preview window

To finish up our more advanced invoice, we will add a logo to the header. Since there are two headers, the
logo will need to be added in both places. That is actually very easy to do, since we can copy it from one
band to the other with exact placement. Here is an excerpt showing the logo placement:
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The invoice design with added logo

After rerunning the report, the print preview shows our newly placed logo image:

The invoice with the logo in the print preview window

The quality of the image in the print preview window seems to be less than ideal, but once it has been
printed (independently of whether it is printed directly or from the print preview window) the resulting
output is of very good quality, as can be seen in this extract from the PDF output:
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An extract of the invoice printed to PDF and zoomed to 200%

Tip

We have noticed some oddities with printed PNG format images that have a transparency
layer. Although the transparent area looks white on the screen, it prints black on the print
out. Converting the image to TIFF seemd to cure this for us. We will be looking at the reason
this happens with PNG in a future release.

Summary
In this chapter we have learned about the Graphic Report Designer and how to use it to create both basic
and sophisticated reports. The Graphic Report Designer has a lot of power to offer, even without using
any program code to enhance it. Still, if what it provides is not quite enough, after loading the report in
program code, each report form page has its own onoutput event where at the point where the chunk of
output has been created, it is passed to the event handling code and changes can then be made to the output
chunk before it is added to the report output page. Those changes do not affect the underlying template.
This ability makes it possible to create very precise output without needing to write very much code to
accomplish it, by using the functionality of the report engine, and then adding in only the bit extra that is
required to achieve your specific goals.
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